Blog
News

Level Up! Shivtr turns Eleven!

News · Nov 27, 2017


It's almost hard to believe, but we launched Shivtr eleven years ago on this day! Yes, today is Shivtr's 11th birthday!

2017 has been an interesting year with the announcement of Classic WoW. Almost a return to our roots! We got our start with WoW so it will always hold a special significance to us, as Shivtr was once simply an awesome website for our WoW guild. Now it has grown to become one of the most popular guild hosting services around, home to more than 2 million gamers and serving millions of page views every month!

Thanks again to everyone who helps support and promote Shivtr, you guys are awesome! =)

38 Comments

Fulkinini ·
Great job, let's make those next 11 years count ;)
Zaph ·
Thank you for providing a great guild hosting service with awesome features. I have noticed a few mobile issues so was wondering if these were going to be addressed:

Adding characters

  • The class combinations aren't working properly there are issues like Druid + Shaman don't exist, and you can create Pandaren Demon Hunters.
  • On mobile you can't select a realm, so the armory update won't work.

Other

  • Custom pages do not work in mobile, it was mentioned it would be coming soon in 2012. I link to specific pages on our community Discord but many people I found are using their phone to view and getting blank pages. Could we get his implemented soon please, more and more people are using mobile to view the sites and it's a bit annoying having to keep explaining to everyone who asks to go to the desktop version on their phones.
  • There is a way to go to Desktop version and site but not back to mobile.
  • As site admins can we have an option to force desktop version of the site if the mobile version is not functionality, we would rather have people see desktop if custom pages / character creation isn't working.
Staff
8 Toes ·
We will be switching the main themes to be responsive and ditching the mobile client in 2 updates; this should resolve most of these issues; the problems in the past has been this can break some themes but we have most of those situations figured out now =)

The next update will be to add https to all sites, which will happen in january when lets encrypt adds wildcard certs; the mobile update will be the next one, probably the following month =)

Cheers,
Ula Vii ·
ooooo just saw this post of yours 8 Toes, great news about the HTTPS option ๐Ÿ˜€

Will the responsive themes be optional or will all current ones be replaced? My guilds theme is heavily modified so I'm concerned that I'm going to wake up and find the site totally broken. I don't mean because your side of things won't work, I just mean because the overrides I made using custom CSS may not work anymore until I rewrite them.

Had another suggestion/request. With the img BB code could you please add an option for a thumbnail link? Currently we can do:

[img overlay=true size=320x240 ignore-this-attribute]http://some-large-image.jpg[/img]

(the ignore-this-attribute is just to stop this reply converting what I wrote to a blank image box)

That lets us scale a large image down and open it in the overlay when clicked. This is fine for a single image but when members want to link several images in one go it leads to long page loading times. My request is that we can do something like:

[img overlay=true size=320x240 thumbnail=http://some-smaller-image.jpg]http://some-large-image.jpg[/img]

What would be extra sweet is that if we used the toolbar button to link to an "original.jpg" image from the s3.mmoguildsites.com store that it would autopopulate the thumbnail link with the "large.png" version.
Staff
8 Toes ·
The https option is delayed a bit as Lets Encrypt delayed their wildcard rollout til Feb 27th - but once they are live we will be adding this =)

For responsive themes, we want to ensure this update won't break existing sites; one option we are looking at is simply to wrap existing custom css in a media query so it only applies to screen sizes larger than mobile (so your existing css wont affect the mobile changes) - this will depend how much existing users already use media queries in their custom css tho.

For making thumbnails link to bigger images, you can do this with bbcode =) for ex:

[url=http://path-to-big-image][img]http://path/to/small/image[/img][/url]

To directly support this with image overlays would be nice, but with our current setup would require us to store all linked images and process them, which would not be ideal; we are considering moving to an ondemand image processing library (cloudinary), if we do something like this will be easier to support =)

Cheers,
Staff
8 Toes ·
ps. if you want to show bbcode here you can wrap it in a [code] tag and it will show it =)
Ula Vii ·
I think it might be better to not wrap the custom CSS in a media query since the sites will still look weird on smaller displays with none of their customisations. At least with the custom CSS basic changes will still be visible on tablets/mobiles until we have time to update our theme customisations.

I understand the difficulty in deciding the route to take with this update. I think it's really cool that we'll be able to make responsive versions of our sites.

About the image thumbnails; yeah I know how to link like that, I just meant specifically for the overlay version. A couple of examples of what I mean:

http://strokemywookie.com/pages/competitions
http://strokemywookie.com/events/850313 (my comment on the event)

To enable the image overlay I had to link to the full size version which means when somebody loads the page they are loading a lot of large images (event though I used the size attribute to make them look smaller initially). Like the ones I link in the event comment total about 5.5MB on my system. I didn't want to link to them in the way you showed as it will put people off checking out the images/break their immersion.

Why would the thumbnail change mean having to use a different image host? You already do the image processing:

http://s3.mmoguildsites.com/s3/gallery_images/964474/small.png
http://s3.mmoguildsites.com/s3/gallery_images/964474/large.png
http://s3.mmoguildsites.com/s3/gallery_images/964474/original.jpg

I just meant that we could use the large.png version as a thumbnail on our image links:

[img overlay=true size=320x240 thumbnail=http://s3.mmoguildsites.com/s3/gallery_images/964474/large.png]http://s3.mmoguildsites.com/s3/gallery_images/964474/original.jpg[/img]
Staff
8 Toes ·
Ah I see, the [img] tag can work with images from anywhere, so I thought your images may have been hosted elsewhere, which would then require the processing...

Making this for our own images could work; tho an option for all images may be best... we will need to review some options for mobile optimizations anyways tho so can see what works =)
Ula Vii ·
Not sure if you considered this already but I thought I'd mention it. Inside the custom CSS and in site content blocks (both Text & HTML) there are a lot of links to images stored in the galleries, so a CSS one might be:

background: #410607 url("http://s3.mmoguildsites.com/s3/gallery_images/782741/original.jpg") repeat center center;

Will you be using the SSL certificates for the mmoguildsites.com s3 subdomain? If so then do you think you could write a one-shot script to run through all the custom CSS blocks and site content blocks and replace http:// with https:// for all links to that specific domain?

  1. This will avoid losing the green lock due to "mixed content"
  2. It will save me a lot of work ๐Ÿ˜
  3. It will help guild sites were the original theme developer is no longer active
  4. Old content like raid guides, news posts, side blocks etc will also not break the green lock
I know pages that reference remote images will still have the mixed content warning but that is beyond your control.
Staff
8 Toes ·
Yes we will need to update all of our image paths when we switch to https, which should be at the end of this month =)

For updating CSS, we were not planning to do this for all sites, as most sites using images in css likely link to external hosts, but I can run a find/replace on the CSS for your site when we push this live =) [and for anyone else who happens to see this comment welcome to request this as well]
Ula Vii ·
Ha I can do a CSS copy and replace myself since it is just one file and I have it backed up locally anyhow so super fast with my code editor.

The bigger request was for you to do a search and replace in the Text & HTML blocks on the site including news and forum posts. Again, I can do that myself but that will be much more involved...
Staff
8 Toes ·
We will definitely be doing some search/replace on paths, since the paths of our gallery images and others will all change; atm not sure exactly which ones we will all do automatically, but we will try to keep it as easy as we can for most guild sites =)
Ula Vii ·
Are the gremlins with the website images due to you working on the system update? Lots of our theme images keep disappearing and then reappearing later on. I mean on different page loads, not flicking while looking at the page.

Disappointing news about the Let's Encrypt wildcard delays. Latest news sounds good but still no release date:

"March 5 Update: Testing continues. Weโ€™ve found and fixed at least one major issue524 with ACMEv2 support and made a number of improvements since the last update here. No release date yet but weโ€™re getting closer. Thank you for your patience."
Ula Vii ·
Random image links seem to of changed across the site. Lots of images in the theme, side blocks and news/forum posts are now dead. They have linked to the images in the original format:

http://s3.mmoguildsites.com/s3/gallery_images/959226/original.jpg

But now is two other formats (same image):
http://s3.amazonaws.com/s3.mmoguildsites.com/s3/gallery_images/959226/original.jpg

(Different image):
http://cloudfront.shivtr.com/theme_images/3776220.jpg
Staff
8 Toes ·
Thanks for reporting this; we have been changing a few things around in prep for https but missed that these paths got changed >_<

I have run a few scripts now which should have corrected the paths for news entries, user avatars, and group discussions; scripts to fix this for blocks and forums are still running but should finish in a few hours.

You mentioned images in the theme broke? Can you provide an example of this and I'll get it sorted =)

Cheers,
Ula Vii ·
The CSS one was just because it pointed to an old link:

body.classic
{
background-image: url("http://s3.mmoguildsites.com/s3/gallery_images/734029/original.jpg");
}


so I just had to update it to the new link address. I think that was the only instance where this happened. Most of the issues were in the side blocks, news page and custom pages like this one (which is still missing half the images):

http://strokemywookie.com/pages/galactic_conquest
Staff
8 Toes ·
the side blocks and news should all be fixed now; thanks for mentioning the pages these should now also be fixed. (the script to update all forum posts is still running; but once its done any images linked in forum posts should also be fixed) =)
Staff
8 Toes ·
ps. you appear to have a bug in your css:

body.classic
{
background-image: url("http://cloudfront.shivtr.com/theme_images/3739325.jpg'");


(there is an ' after .jpg which is causing the image to not load)
Ula Vii ·
Ha thanks. Link doesn't work anyhow since the image path seems to of changed again.

Originally I had an override to clear the background that is auto-added to the .wallpaper div so the one I manually added to the body would display. When the image links went goofy I reverted to using the default .wallpaper version.

There's a ton of redundant styles in there now due to me adding/removing/changing parts of the site over the last 6 years. When you finish the changes on your side I'll do a rewrite.
Ula Vii ·
Not sure if there is a delay or not but I noticed the "Space Used" progress bar at the bottom of the gallery doesn't seem to be updating. Ours is the 2GB package and the bar says we are at 99.78% so I cleared out a bunch of images yesterday. Today the bar is still showing the same percent. I was able to upload more images but the bar still didn't change.

Also, I had a realisation tonight. We run a lot of server events so I post the details and summaries on Reddit and the SWTOR forum. In there I link to the screenshots so of course all those links are going to be dead. Is there anyway you can setup an auto redirect?
Staff
8 Toes ·
Thanks for the report on this, our gallery space column needed to be increased; this is now updated, and likely may have jumped your file storage counter a bit.

For setting up a redirect, we decided to abandon the old domain we were paying for mmoguildsites.com, as its not been used for many years now, but is what these were linked through, so unfortunately we cannot do a redirect =(
Eclisse ·
Thank you for your excellent hosting service.

I am currently making a site for D&D tabletop RPG players. We have many .PDF documents (maps, floorplans etc.) and would love to be able to upload them as pdf so minimize the memory footprint. Is it possible to integrate pdf into the current media storage system?
Staff
8 Toes ·
Currently our only file storage is the gallery section which only supports images; you could upload these to google docs or so and link to them from there =)
Eclisse ·
Thanks for the idea, I will look into that.

xoxox
Ula Vii ·
Hi, with the updates coming up soon, will you be changing the payment plans? We're currently on the Epic plan but keep running out of room for the image gallery. If we switch to the Mythic plan for 1/2 as much again then we'll only be using the extra file hosting space. Just want to know if anything is going to change before I make the final decision on what to do. One idea is to use a third party image host but I'm not keen on having to maintain two galleries.
Staff
8 Toes ·
We are not planning to change our plans soon, but you have been with us a long while so I'll make you a special offer =)

If you wanted to upgrade to the Mythic plan, I'll give you the storage of Mythic+Epic, so 6GB total =) Just reply back here after or email support@shivtr.com and I can apply it for you.

Hope that helps =)
Ula Vii ·
Wow that's awesome, thank you very much. Conferring with my officers.

If I switch to a yearly plan do I have to pay it all upfront or is it a commitment to not change package for a year but with a monthly cost?
Staff
8 Toes ·
it would be all upfront then
Ula Vii ·
Alrighty then, let's do it! 1 year on Mythic please. I tried to use the Upgrade option on the site but it said there was a problem. I want to use a different paypal account than the one currently associated with the account so maybe that is what caused the problem.
Staff
8 Toes ·
You should be free to use any Paypal account when paying, it directs you to their site to make the payment. If it fails it may be due to an issue with the Paypal account (for example maybe the credit card attached is expired), or it may be an issue on Paypal's end (for example if the purchase is larger than normal it may be flagged and blocked, or if you are paying from a different location than normal, etc.)

We also have payments through Stripe, which is similar to Paypal, and powers lots of popular stores like Shopify, Squarespace, etc.; using Stripe we never see your credit card data; its proceeded on Stripe's end and they just send us tokens, so if Paypal will not work for some reason Stripe is a very safe option =)

Cheers,
Ula Vii ·
After I login with the 2nd paypal account it redirects me to this page:

https://screenshots.firefox.com/zHtA5wqKzjrw2hqg
/www.paypal.com

Steps to reproduce:
  1. I go to the Billing page in Shivtr admin
  2. Select Yearly from dropdown and then Upgrade below Mythic
  3. It shows me a summary screen for the order and a Paypal login button
  4. I click login and enter the details for the 2nd Paypal account
  5. See error message in screenshot
  6. Game over!
The original Paypal account is a work one but over the last year we have been taking donations towards payments on a special guild only paypal account. Currently I transfer the money from that account into the other one so the re-occurring payments are unaffected. Now since we're making a one off big payment I want to switch it to the special guild account. It definitely 100% has enough money in it to cover the payment.
Staff
8 Toes ·
Ah in that case try canceling your current subscription and then resubscribing to the new plan you want and it should work =)
Ula Vii ·
OK cancelled but I'll have to wait a few weeks until I can select the Mythic option as the buttons are greyed out with "Wait":

You are on the Epic Plan (Canceled).
Your canceled subscription remains active until Apr 25, 2018 at 11:12 AM.


It's alright, I'll set an alarm so I don't forget, no biggie. I can free up another few % from the gallery to allow uploads until then.
Staff
8 Toes ·
That means your last sub payment was just 5 days ago, if you prefer I can simply refund that payment and remove it, then you can upgrade now and not have to worry about freeing space for the next few weeks =)

Prefer me to do this?
Ula Vii ·
ooo yeah let's do that!
Staff
8 Toes ·
Ok your payment has been refunded and I set your site back to the free plan which should let you subscribe now to Mythic =)

If you have any troubles with it please let me know =)
Ula Vii ·
Yaaay went through fine this time and the Plans section now shows we're on the Mythic option.

Thank you very much ๐Ÿ˜€
Staff
8 Toes ·
Sweet, I just updated your site as well and it should now show you have 6GB space for the gallery =)

Hope you have a great weekend,

If you were logged in you could add your comments to the discussion!